Applies To:

Show Versions Show Versions

Manual: F5 Access and BIG-IP Edge Apps Client Compatibility Matrix
Manual

Original Publication Date: 08/20/2013
Updated Date: 11/08/2018

F5 Apps Compatibility Matrix

Software support

For client software releases, we will provide support for the two most recent versions of a product. However, bug fixes and new features can be made on the next client version. BIG-IP software releases have their own support policy. We list compatibility with the most recent BIG-IP version on each release.

Android and F5 Access and Edge Apps

F5 Networks supports Android™ versions 4 through 8.

For Network Access support, install F5 Access or the F5 BIG-IP Edge Client from Google Play. Android 5 and later is supported on BIG-IP Edge Client version 2.0.8 and higher, and F5 Access 3.0.1 and higher.

F5 Networks supports the BIG-IP Edge and F5 Access apps with the following BIG-IP versions. Upgrade to the most recent version of F5 apps.

Note: The app previously known as BIG-IP Edge Client has been renamed F5 Access as of version 3.0.0.

Edge and F5 Access Apps for Android Supported BIG-IP Versions
F5 Access 3.0.4 11.5.1, 11.5.7, 11.6.3, 12.1.3, 13.0.0, 13.1.0, 14.0.0
F5 Access 3.0.3 11.5.1, 11.5.7, 11.6.3, 12.1.3, 13.0.0, 13.1.0, 14.0.0
BIG-IP Edge Client 2.0.8 11.5.1, 11.5.7, 11.6.3, 12.1.3, 13.0.0, 13.1.0, 14.0.0

iOS and F5 Access and Edge Apps

F5 Networks supports Apple® iOS® versions 10, 11 and 12.

Note: F5 Access Legacy 2.1.x is not supported on iOS 12. Only F5 Access 3.0.0 and later is supported on iOS 12.

For Network Access support, please install F5 Access through the App Store.

F5 Networks supports F5 Access apps with the following BIG-IP software versions. Upgrade to the most recent version of the F5 Access apps.

Note: The app previously known as BIG-IP Edge Client has been renamed F5 Access as of version 2.1.0.

Edge and F5 Access for iOS Supported BIG-IP Versions Supported iOS versions
F5 Access 3.0.3 11.5.7, 11.6.3, 12.1.3, 13.0.0, 13.1.0, 14.0.0 11, 12
F5 Access 3.0.2 11.5.7, 11.6.3, 12.1.3, 13.0.0, 13.1.0, 14.0.0 11, 12
F5 Access 3.0.0 11.5.1, 11.5.7, 11.6.3, 12.1.3, 13.0.0, 13.1.0, 14.0.0 11, 12
F5 Access Legacy 2.1.2 11.5.1, 11.5.7, 11.6.3, 12.1.3, 13.0.0, 13.1.0, 14.0.0 10, 11

macOS and F5 Access

F5 Networks supports macOS 10.12.2 and later, including macOS 10.13 (High Sierra) and macOS 10.14 (Mojave).

F5 Access for macOS Supported BIG-IP Versions
F5 Access 2.0.0 13.0.0, 13.1.0, 14.0.0
F5 Access 1.0.0 13.0.0, 13.1.0, 14.0.0

Windows Phone and Edge Apps

F5 Networks supports Microsoft® Windows Phone® version 8.1.

For Network Access functionality, install F5 BIG-IP Edge Client through the Microsoft Windows Phone Store.

Edge Apps for Windows Phone Supported BIG-IP Versions
BIG-IP Edge Client 1.1 11.5.1, 11.5.7, 11.6.3, 12.1.3, 13.0.0, 13.1.0, 14.0.0
BIG-IP Edge Client 1.0 11.5.1, 11.5.7, 11.6.3, 12.1.3, 13.0.0, 13.1.0, 14.0.0

Windows 10 and Windows 10 Mobile and F5 Access

F5 Networks supports Microsoft® Windows® 10 and Windows® 10 Mobile.

For Network Access functionality, install F5 Access through the Microsoft Windows Store.

F5 Access for Windows 10 Supported BIG-IP Versions
F5 Access for Windows 10 1.2 11.5.1, 11.5.7, 11.6.3, 12.1.3, 13.0.0, 13.1.0, 14.0.0
F5 Access for Windows 10 1.3 11.5.1, 11.5.7, 11.6.3, 12.1.3, 13.0.0, 13.1.0, 14.0.0

Chrome OS and F5 Access App

F5 Networks has fully qualified compatibility with Google Chrome version 56 and later.

For Network Access functionality, install F5 Access from the Chrome Web Store.

F5 Access for Chrome OS Supported BIG-IP Versions
F5 Access for Chrome OS 1.0.4 12.1.3, 13.0.0, 13.1.0, 14.0.0
F5 Access for Chrome OS 1.0.3 12.1.3, 13.0.0, 13.1.0, 14.0.0

 

Regarding Desktop Edge Client and Helper Applications version differences

Windows and macOS operating system software and peripheral applications are updated often. These updates necessitate changes in APM Client software packages to ensure maximum compatibility and performance. F5 highly recommends that customers use the latest available versions of both the APM Client software and the BIG-IP server; however, we understand that deployment cycles for network infrastructure and desktop infrastructure can occur on different schedules. This can lead to situations where different versions of the client and server software are used together. F5 supports older or newer APM clients (supported versions only) connecting to older or newer BIG-IP APM servers (supported versions only). However, if a compatibility problem is discovered in a mismatched deployment, a workaround may not exist and an upgrade to either the server or client may be required, as determined by F5.

Other considerations:

  1. F5 performs proactive testing only between the latest client and server versions.
  2. Starting with BIG-IP 13.1, the APM Clients package can be updated independently of BIG-IP. Prior versions of BIG-IP lacked this capability. For more detail, see the following solution article: https://support.f5.com/csp/article/K52547540
  3. This statement does not modify our product support lifecycle policy. For more information, please see: https://support.f5.com/csp/article/K8986