Applies To:

Show Versions Show Versions

Manual: BIG-IP APM Client Compatibility Matrix
Manual

Original Publication Date: 12/07/2010
Updated Date: 03/02/2017

Notice regarding F5 End of Technical Support

IMPORTANT:This version of BIG-IP software has reached the End of Technical Support milestone. This content is no longer supported or maintained. For information about the BIG-IP software lifecycle policy, see article K5903 in the AskF5 knowledge base. You can find compatibility matrices for supported versions in the BIG-IP APM Knowledge Center in AskF5.

Testing Model

F5 Networks tests the functionality of Access Policy Manager controller on the most-used platforms, and ensures compatibility with the most-used operating systems (OS), browsers, and applications.

Supported Access and Endpoint Security Features

Feature

Operating System

Windows

Linux

Mac

ActiveSync1

+ n/a +

Anti-virus and Firewall Checker2

+ + +

BIG-IP® Edge Client

+ n/a +

Cache and Session Control

+3 n/a n/a

Custom Dialer

+ n/a n/a

DNS Relay Proxy Service

+ n/a n/a

File Check

+ + +

Group Policy

+ n/a n/a

Machine Certificate Checker

+ n/a n/a

Network Access

+ +4 +4, 5

OS Check

+ + +

Process Check

+ + +

Protected Workspace

+6 n/a n/a

Reconnect to Domain

+ n/a n/a

Registry Check

+ n/a n/a

Traffic Control Service

+ n/a

n/a

Virtual Keyboard

+ + +

Web Applications

+ + +
Portal Access + + +

Windows Info

+ n/a n/a

1 See Qualified Mobile Devices section below
2 Visit www.askf5.com for a list of supported antivirus and firewall vendors
3 Cache and Session Control does not remove forms data, passwords and cookies under Firefox®
4 For Linux® and Mac OS®, the Network Access feature does not work with a proxy server
5 Apple® iPhone and Apple® iPad do not include native support for Network Access. Download the BIG-IP Edge Client app from the iTunes App store to use Network Access on iPhone or iPad
6Protected Workspace is supported on 64-bit versions of Windows, except on Windows XP 64-bit

OS / Browser and Browser Compatibility

F5 Networks® supports the listed operating systems and browser releases, with the latest service pack or service pack equivalent, for up to 3 years from time of initial release, as long as the listed operating systems and browsers are still supported by the vendor.

If an operating system or browser vendor ends mainstream support before the end of that 3 year period for a release or service pack, F5 Networks® will also end support at the same time. Once an operating system or browser has surpassed the 3 year date from release, F5 Networks® will continue to monitor the user base of this operating system or browser release. When a release reaches a usage level that can no longer justify development, test, and support resources, we will issue an EoL (End of Life) Solution at least three months prior to the planned EoDS (End of Development Support).

Microsoft's introduction of Servicing Branches in Windows 10 has changed the F5 Networks® support policy for Windows 10 as follows:
F5 Networks® will support Microsoft Windows 10 Current Branch (CB) releases, Current Branch For Business (CBB) releases, and Long Term Servicing Branch (LTSB) releases, up to two years from the initial release date, as long as such a release is within the "mainstream support" period.
Once a release has passed two years from the release date, F5 Networks® will monitor the user base of this release. When a release reaches a usage level that can no longer justify development, test, and support resources, we will issue an EoL (End of Life) Solution at least three months prior to the planned EoDS (End of Development Support).

See https://support.microsoft.com/en-us/help/13853/windows-lifecycle-fact-sheet for more details. For specific information about which builds Microsoft supports as part of its servicing branches, see https://technet.microsoft.com/en-us/itpro/windows/manage/waas-overview#servicing-branches.

Important: This policy only applies to the BIG-IP end-user interfaces, and not the administrative web console for BIG-IP, or any other F5 product.

Microsoft® Windows OS

Operating System

IE 9.0*

IE 8.0

IE 7.0

Firefox® 8.x**

Firefox® 3.x

Windows® 7

+ + n/a + +

Windows® 7 64-bit (32-bit compatibility mode)

+ + n/a + +

Windows® 7 SP1

+ + n/a + +

Windows® 7 SP1 64-bit SP1 (32-bit compatiblity mode)

+ + n/a + +

Windows Vista® SP1

+ + + + +

Windows Vista® SP1 (32-bit compatiblity mode)

+ + + + +

Windows Vista® SP2

+ + + + +

Windows Vista® 64-bit SP2 (32-bit compatibility mode)

+ + + + +
Windows® XP SP2 ( 64-bit) n/a + + + +

Windows® XP SP3 ( 32-bit)

n/a + + + +

Microsoft® Internet Explorer is abbreviated in the tables as IE.

*Supported by 10.2.1-HF2

**Supported by 10.2.1-HF2 build496.40

Linux Operating Systems

The following 32-bit x86 and64-bit x86_64 Linux operating systems (OS) listed in the table have been qualified by F5 Networks. Other 32-bit x86 and 64-bit x86_64 Linux distributions may work, but have not been explicitly qualified. Kernel support for PPP interfaces must be enabled and must be installed. libc version 2 or later is also required

Operating system

Firefox®8.x*

Firefox® 3.x

Ubuntu® 9.10

+ +

Ubuntu® 10.04

+ +

Ubuntu® 10.10

+ +

Debian® 5

+ +

CentOS 5.5

+ +

Fedora 13

+ +

Fedora 14

+ +

openSUSE® 11.3

+ +

*Supported by 10.2.1-HF2 build496.40

Mac OS X

Operating System

Firefox® 8.x*

Firefox® 3.x

Safari 5.x

Apple® Mac OS® X 10.7.x (Intel platform)**

+ n/a +
Apple® Mac OS® X 10.6.x (Intel platform) + + +

Apple® Mac OS® X 10.5.x (PPC and Intel platforms)

+ + +

*Supported by 10.2.1-HF2 build496.40

**Supported by 10.2.1-HF2 build 496.42

Portal Access Compatibility

The following applications were qualified for compatibility in Portal Access mode.

  • Microsoft® Outlook® Web Access (OWA) 2003, 2007, 2010
  • Microsoft® SharePoint® 2003, 2007, 2010 and Services 3.0
    • SharePoint has been tested for compatibility with MS Office 2007 for Windows on all supported combinations of Windows.
  • Microsoft® Communicator® 2007
  • IBM Lotus® Domino® Web Access 8.0
  • Oracle® Portal 3.0 (10g Release 2, Version 10.1.2)
  • Oracle®PeopleSoft Portal and HR Version 9
  • SAP® ERP Central Component (ECC) 2005 and SAP NetWeaver ® 7.0 (2004s) SP12

Outlook Anywhere Compatibility

The following versions of the client applications were tested for compatibility with Outlook Anywhere.

  • Microsoft® Office® 2007 for Windows®
  • Microsoft® Office® 2010 for Windows®
  • Microsoft® Office® 2011 for Mac®

Citrix Compatibility

Citrix Presentation Server 4.5, XenApp versions 5 and 6 were qualified for compatibility with F5 BIG-IP Acess Policy Manage Secure Proxy. The following clients were tested:

  • Citrix Online Plugin for Windows (Full and Web) ver. 12.0.3.6xxx
  • Java ICA client (9.7)
  • Citrix OnlinePlugin and Dazzle for Macintosh ver 11.1.0
  • Citrix Receiver version 4.0 for iPod
  • Citrix Receiver version 4.2 for iPad

Qualified Mobile Devices

  • Windows Mobile 6, 6.1, and 6.5, using PocketIE 6.0
    Tested devices:

    • HTC Touch
    • HTC S710VOX
    • HTC Pure
    • AT&T Tilt 8900 (HTC Kaiser 110)
    • Samsung Omnia II (SCH-i920)
  • Apple® iOS® 3.x, 4.x and 5.x devices, using Safari web browser
    Tested devices:

    • iPhone version 3.1 (7C144) and 4.1 (8B117)
    • iPod Touch iOS 3.1.2 (7D11), iOS 3.1.3 (7E18), iOS 4.0.2 (8A400) , iOS 4.1 (8B118), iOS 4.3 (8F190), iOS 4.3.3 (8J2), iOS 4.3.5 (8L1) and iOS 5.0 (9A334).
    • iPad version 3.2.2 (7B500), 4.3.5 (8L1) and 5.0 (9A334)

Note: The Mobile Devices listed previously have been fully qualified by F5 Networks. Other Windows® Mobile-based devices may work, but have not been explicitly qualified. Please see the BIG-IP® Edge Client™ Software Deployment Guide for Windows Mobile 5 and later on http://support.f5.com for more information on device requirements.